PHP 5.6 End of life. What should I do?

Written by Daniel Partadzhiev
From 31 December 2018 PHP 5.6 is no longer being maintained with security support by the PHP.net community, and PHP 7.1 will be no longer actively supported as well. For more detailed information about the supported PHP versions, please click here.

With that being said, the first questions that come to your mind are -

- Will my website be no longer secure?
- Am I exposed to hackers?

Take a deep breath if you're on Kualo's shared hosting, because the answer is almost certainly no!


Here at Kualo we love to always go the extra mile for our customers, and go above and beyond when it comes to hosting solutions that rock. Even though PHP 5.6 is not going to be maintained by the PHP.net community, you shouldn't feel overly concerned because, as you can guess, for your peace of mind we already have a solution.



 

In this post, we are going to provide you with more detailed information regarding:
  • The Hardened PHP versions that we support.
  • What are the benefits of switching to PHP 7.2?
  • What is the impact of not upgrading?
To start with, all of our shared hosting servers are equipped with CloudLinux OS which comes with HardenedPHP as standard.

What is HardenedPHP?



HardenedPHP secures old and unsupported versions of PHP. In those old versions, including the widely used 5.2, 5.3, 5.4, 5.5 and 5.6 versions, vulnerabilities in PHP, even if discovered, are not patched by the PHP.net community.

HardenedPHP takes care of all this.

As a top-notch hosting provider, we  appreciate that the security of your websites is paramount. With this in mind, there is absolutely nothing to be concerned about as even running with an older HardenedPHP version, PHP is secure.

Of course, if your application is requiring PHP 5.6, it is worth verifying that there are no updates available for it. Whilst PHP itself is hardened and secured, it may still be possible that the application itself contains a vulnerability that might be patched in a newer release.

If you're running on custom code, and you're sure that it's secure - then you should be safe on our servers.

What if your sites run on your own VPS or Dedicated server?



If your server runs on CloudLinux, then it already supports all HardenedPHP versions.

In case that your server does not run on CloudLinux, we can advise you to either switch to PHP 7.2 (if your application supports it) or upgrade your server to run on CloudLinux in order to take benefit of the Hardened older PHP versions.

If you're unsure what operating system your server with Kualo runs, don't hesitate to reach out to us.

What are the benefits of switching to PHP 7.2?

PHP 7.2 includes important security measures, new additions to the core, and modern cryptography and faster load speed for sites. The latest updates to PHP version 7 include performance enhancements and exciting new features.

Please keep in mind that not upgrading your server or using a non-hardened PHP versions that are no longer supported, may cause serious security issues with your server and website.

Therefore, please don't wait until it is too late and don't put yourself at risk!

And whilst no security feature can ensure 100% protection, keeping your server and website up to date puts you one step ahead in terms of saving time and money, and having a more pleasurable and hassle free hosting experience.

Don't miss out!

Get our updates on web development, online marketing, customer support and (of course) web hosting!